Вопрос по информатике:
Составить программу , которая заполняет массив А[1..10] случайными целыми числами в диапазоне от 1 до 50 и выводит на экран минимальный элемент массива
- 02.10.2016 11:37
- Информатика
- remove_red_eye 7851
- thumb_up 30
Ответы и объяснения 1
CONST k=10; {k - количество чисел в массиве}VAR a:array[1..k] of integer; i,summ,n:integer; {i - счетчик цикла, summ - сумматор, n - количество элементов массива с четным значением} sr:real; {sr - среднее арифметическое} BEGIN summ:=0; n:=0; {Обнуляем счетчики} for i:=1 to k do begin a[i]:=random(50); {Заполняем массив случайными числами} write (a[i],' '); {Выводим массив} if a[i] mod 2=0 then begin summ:=summ+a[i]; {Находим сумму элементов массива с четными значениями} n:=n+1 end end; sr:=summ/n; {Находим среднее арифметическое} writeln; writeln (sr:0:2) {Выводим среднее арифметическое}END.
- 03.10.2016 09:16
- thumb_up 31
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.