Вопрос по информатике:
Дается последовательность из N чисел. Выведите разницу между максимальным и минимальным элементами последовательности.
Формат входных данных
Первая строка входного файла содержит целое число N (1 <= N <= 100000). В следующей строке задаются N положительных целых чисел, каждое из которых не превышает 100000.
- 16.07.2018 11:09
- Информатика
- remove_red_eye 13991
- thumb_up 26
Ответы и объяснения 1
Сделано через динамический массив!
var a:array of Integer; n,i,max,min:Integer;
begin
Readln(n);
SetLength(a,n);
for i:=0 to Length(a) do
readln(a[i]);
max:=a[0];
for i:=0 to Length(a) do
if a[i]>max then
max:=a[i];
min:=a[0];
for i:=0 to Length(a) do
if a[i]
Writeln;
Writeln(max-min);
readln;
end
- 17.07.2018 23:08
- thumb_up 37
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.