Вопрос по информатике:
Помогите пожалуйста)
Составьте программу,которая заполняет массив a[1..8] случайными целыми числами в диапазоне от 1 до 10 и выводит на экран количество элементов с четными значениями и сумму элементов массива с нечетными значениями.
- 01.06.2018 10:03
- Информатика
- remove_red_eye 15998
- thumb_up 31
Ответы и объяснения 1
Var a:array[1..8]of integer;
i,k,s:integer;
begin
for i:=1 to 8 do
begin
a[i]:=random(10)+1;
write(a[i],' ');
if a[i] mod 2=0 then k:=k+1
else s:=s+a[i];
end;
writeln;
writeln('kol-vo chet elem:',k,' summa nechet:',s);
end.
- 02.06.2018 14:19
- thumb_up 7
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.