Вопрос по информатике:
Составьте программу, которая формирует массив из пятнадцати случайных целых чисел от -20 до 20 и отрицательные числа возводит в квадрат, а из неотрицательных извлекает квадратный корень.
- 06.07.2017 23:20
- Информатика
- remove_red_eye 19468
- thumb_up 37
Ответы и объяснения 1
Program rp1;
uses crt;
var a: array [1..15] of integer; i: integer;
begin
clrscr;
randomize;a[i]:=random (41)-20;
writeln ('massiv ');
for i:=1 to 15 do
write (a[i], ' ');
for i:=1 to 15 do
if a[i]< 0 then a[i]:=sqr (a[i]) else a[i]:=sqrt (a[i]);
writeln ('novij massiv ');
for i:=1 to 15 do
write (a[i], ' ');
end.
- 07.07.2017 04:27
- thumb_up 11
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.