Вопрос по информатике:
Паскаль АВС
составить программу, которая создает массив случайных чисел размером (N x M), выводит его на экран и вычисляет произведение ненулевых элементов массива.
- 11.02.2016 18:05
- Информатика
- remove_red_eye 3459
- thumb_up 21
Ответы и объяснения 1
Program asd;
Const n=5;
m=4;
Var i,j,p:integer;
A:array[1..n,1..m] of integer;
BEGIN
For i:=1 to n do
begin
For j:=1 to m do
begin
A[i,j]:=Random(10);
Write(A[i,j]:3);
end;
Writeln;
end;
P:=1;
For i:=1 to n do
For j:=1 to m do
begin
if A[i,j]0 then p:=p*A[i,j];
end;
Writeln('Произведение ненулевых элементов массива: ',p);
END.
- 12.02.2016 08:09
- thumb_up 32
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.