Вопрос по информатике:
По заданному числу n от 1 до 365 определите, на какое число какого месяца приходится день невисокосного года с номером n.
Входные данные
Дано одно целое число n.
Выходные данные
Программа должна вывести два числа: число месяца (от 1 до 31) и номер месяца (от 1 до 12), соответствующие дню с номером n.
- 20.12.2017 22:39
- Информатика
- remove_red_eye 9072
- thumb_up 10
Ответы и объяснения 1
Var a: integer;begin read(a); if (a >= 1) and (a <= 31) then write(a,' ',1); if (a >= 32) and (a <= 59) then write((a - 31),' ',2); if (a >= 60) and (a <= 90) then write((a - 59),' ',3); if (a >= 91) and (a <= 120) then write((a - 90),' ',4); if (a >= 121) and (a <= 151) then write((a - 120),' ',5); if (a >= 152) and (a <= 181) then write((a - 151),' ',6); if (a >= 182) and (a <= 212) then write((a - 181),' ',7); if (a >= 213) and (a <= 243) then write((a - 212),' ',8); if (a >= 244) and (a <= 273) then write((a - 243),' ',9); if (a >= 274) and (a <= 304) then write((a - 273),' ',10); if (a >= 305) and (a <= 334) then write((a - 304),' ',11); if (a >= 335) and (a <= 365) then write((a - 334),' ',12); readln; readlnend.
- 21.12.2017 23:22
- thumb_up 36
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.