Вопрос по информатике:
A) Составьте программу, которая заполняет масcив a[10..20] случайными целыми числами в диапазоне от 10 до 20, затем меняет местами первый и последний элементы. Выведите на экран исходный и полученный массивы.
б) Составьте программу, которая заполняет масcив a[10..20] случайными целыми числами в диапазоне от 1 до 100, затем меняет местами максимальный и минимальный элементы. Выведите на экран исходный и полученный массивы.
Программы должны выводиться в Строчку.(write)
- 21.04.2018 08:26
- Информатика
- remove_red_eye 12298
- thumb_up 21
Ответы и объяснения 1
Var
i,x:integer;
m:array[10..20] of integer;
begin
randomize;
for i:=10 to 20 do m[i]:=random(11)+10;
for i:=10 to 20 do write(m[i],' ');
writeln;
x:=m[10];
m[10]:=m[20];
m[20]:=x;
for i:=10 to 20 do write(m[i],' ');
writeln;
end.
2)
var
max,min,i,x:integer;
m:array[10..20] of integer;
begin
min:=10;
max:=10;
randomize;
for i:=10 to 20 do m[i]:=random(100)+1;
for i:=10 to 20 do write(m[i],' ');
writeln;
for i:=10 to 20 do begin if m[i]
end;
x:=m[min];
m[min]:=m[max];
m[max]:=x;
for i:=10 to 20 do write(m[i],' ');
writeln;
end.
- 22.04.2018 04:26
- thumb_up 4
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.