Вопрос по информатике:
Написать программу, которая находит сумму элементов последовательности из 5 целых чисел. Получить новую последовательность путем замены всех ненулевых
элементов исходной последовательности на разность между элементом последовательности и найденной суммой.
- 27.07.2018 07:24
- Информатика
- remove_red_eye 16978
- thumb_up 36
Ответы и объяснения 1
Program Project1;
var
a:array[1..5] of Integer;
i, j, sum:Integer;
s:string;
begin
Readln(s);
sum:=0;
for i:=1 to 5 do
begin
if (Length(s)>=2) then
begin
j:=Pos(' ', s);
a[i]:=StrToInt(Copy(s, 1, j-1));
sum:=sum+a[i];
Delete(s, 1, j);
end
else
begin
a[i]:=StrToInt(s);
sum:=sum+a[i];
end;
end;
for i:=1 to 5 do
begin
if (a[i]0) then
begin
a[i]:=a[i]-sum;
Write(a[i], ' ');
end
else
begin
a[i]:=a[i];
Write(a[i], ' ');
end;
end;
end.
- 28.07.2018 18:02
- thumb_up 15
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.