Вопрос по информатике:
Помогите решить две задичи
Задача: Написать программу, которая
а) все буквы 'а' в строке st заменяет на букву 'о' и выводит новую строку на экран
б) удаляет все буквы 'а' из строки и выводит новую строку на экран
- 23.01.2018 22:07
- Информатика
- remove_red_eye 2555
- thumb_up 44
Ответы и объяснения 1
Var st:string;
i:integer;
begin
writeln('Введите строку:');
readln(st);
for i:=1 to length(st) do begin
if st[i]='a' then
st[i]:='o';
end;
writeln(st);
end.
var st:string;
i:integer;
begin
writeln('Введите строку:');
readln(st);
for i:=1 to length(st) do begin
if st[i]='a' then
delete(st,i,1);
end;
writeln(st);
end.
- 24.01.2018 08:54
- thumb_up 11
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.