Вопрос по информатике:
Составить программу
оценки на соревнованиях по фигурному катанию выставляются 9 судьями. потом одна самая высокая и самая низкие оценки отбрасываются и в зачет идет среднее арифметическое оставшихся оценок. составьте программу, которая определяет зачетную оценку спортсмена. оценки судей ввести в клавиатуры (целые числа от 1 до 6)
- 25.05.2015 20:10
- Информатика
- remove_red_eye 14682
- thumb_up 43
Ответы и объяснения 1
Var
max,min,i:integer;
b:real;
a:array[1..9]of integer;
begin
for i:=1 to 9 do
begin
while (a[i]6) do
begin
write(i,' оценка: ');
readln(a[i]);
end;
if i=1 then
begin
max:=a[1];
min:=a[1];
end;
if a[i]>max then max:=a[i];
if a[i]
end;
b:=(b-min-max)/7;
writeln('Зачетная оценка: ',b);
end.
- 26.05.2015 20:35
- thumb_up 50
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.