Вопрос по информатике:
Написать программу,которая вычисляет среднее арифметическое ненулевых элементов введенного с клавиатуры массива из 10 целых чисел. Помогите пожалуйста,плохо понимаю эти программы(((
- 17.04.2018 02:19
- Информатика
- remove_red_eye 3287
- thumb_up 47
Ответы и объяснения 1
Var a:array [1..10] of integer;
i,count:integer;
s:real;
begin
....//тут ты заполняешь массив как тебе надо
s:=0;
count:=0;
for i:=1 to 10 do begin
if a[i]0 then begin //если элемент ненулевой то
s:=s+s; //суммируем их и увеличиваем счетчик на 1
count:=count+1;
end;
end;
s:=s/count;
writeln('Среднее значение=', s:0:0);
end.
- 18.04.2018 02:18
- thumb_up 5
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.