Вопрос по информатике:
Язык Pascal ABC. Напишите программу:
Дан двухмерный массив A[1..m,1..n]. Написать программу построения одномерного массива B[1..m], элементы которого соответственно равны суммам элементов строк.
- 02.09.2018 21:46
- Информатика
- remove_red_eye 15796
- thumb_up 19
Ответы и объяснения 1
Const
m=100;
n=100;
var
a:array[1..m,1..n]of integer;
b:array[1..m]of integer;
i,j:integer;
begin
for i:=1 to m do
for j:=1 to n do
a[i,j]:=random(200)-100;
for i:=1 to m do
b[i]:=0;
for i:=1 to m do
for j:=1 to n do
b[i]:=b[i]+a[i,j];
for i:=1 to m do
write(b[i],' ');
end.
- 03.09.2018 21:01
- thumb_up 20
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.