Вопрос по информатике:
Составьте программу, которая заполняет массив A[1..10] случайными целыми числами в диапазоне от 1 до 50 и вычисляет среднее арифметическое элементов с чётными значениями элементов массива.
- 13.11.2017 22:01
- Информатика
- remove_red_eye 3246
- thumb_up 11
Ответы и объяснения 2
Var A:array[1..10] of integer;
avg,sum,i:integer;
begin
for i:=1 to 10 do A[i]:=rand(50);
for i:=1 to 10 do begin
if A[i] mod 2 = 0 then sum:=sum+A[i];
end;
avg:=sum/10;
write(avg);
end.
- 14.11.2017 15:09
- thumb_up 4
Begin
writeln("Данный массив: ");
for i:=1 to 10 do begin
a[i]:=random(50)+1; writeln(a[i]," ");
if (i mod 2 = 0) then begin sr:=sr+a[i]; k:=k+1; end;
end;
sr:=sr/k;
writeln("Среднее арифметическое элементов с четными значениями = ",sr);
end.
- 15.11.2017 23:41
- thumb_up 38
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.