Вопрос по информатике:
Написать программу, которая для первых n натуральных чисел находит сумму чётных и произведение нечётных чисел. число n вводится с клавиатуры . выполнить программу для n=13 , записать результат
- 19.12.2017 00:00
- Информатика
- remove_red_eye 7801
- thumb_up 44
Ответы и объяснения 1
Const n=13;
var i,s,p:integer;
begin
s:=0; p:=1;
for i:=1 to n do begin
if (i mod 2 = 0) then s:=s+i;
if (i mod 2 0) then p:=p*i;
end;
writeln("Сумма четных = ",s," , произведение нечетных =",p);
end.
- 20.12.2017 07:01
- thumb_up 33
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.