Вопрос по информатике:
)Какую структуру Будет иметь алгоритм решения следующей задачи? Дано целое положительное число N. Если N — четное, то вычислить N! = 1·2·...·N. Если N — Нечетное то вычислить сумму : 1 + 2 + .+N.Составить программу на паскале
- 15.09.2017 17:46
- Информатика
- remove_red_eye 9043
- thumb_up 25
Ответы и объяснения 1
Разветвляющуюся структуру
var n,f,s,i:integer;
begin
write('Введите целое положительное число N= '); readln(n);
f:=1; s:=0;
if n mod 2 =0
then begin for i:=1 to n do f:=f*i;writeln(n, '!=', f); end
else begin for i:=1 to n do s:=s+i; writeln('S= ', s) end;
end.
- 16.09.2017 09:56
- thumb_up 15
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.