Вопрос по информатике:
Составьте программу, которая заполняет массив A[1..10] случайными целыми числами в диапазоне от 1 до 50 и вычисляет среднее арифметическое элементов с четными значениями элементов массива.
- 12.03.2015 00:39
- Информатика
- remove_red_eye 13613
- thumb_up 9
Ответы и объяснения 1
CONST k=10; {k - количество чисел в массиве}
VAR a:array[1..k] of integer;
i,summ,n:integer; {i - счетчик цикла, summ - сумматор, n - количество элементов массива с четным значением}
sr:real; {sr - среднее арифметическое}
BEGIN
summ:=0; n:=0; {Обнуляем счетчики}
for i:=1 to k do
begin
a[i]:=random(50); {Заполняем массив случайными числами}
write (a[i],' '); {Выводим массив}
if a[i] mod 2=0 then
begin
summ:=summ+a[i]; {Находим сумму элементов массива с четными значениями}
n:=n+1
end
end;
sr:=summ/n; {Находим среднее арифметическое}
writeln;
writeln (sr:0:2) {Выводим среднее арифметическое}
END.
- 13.03.2015 08:19
- thumb_up 6
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.