Вопрос по информатике:
Составьте программу позволяющую найти долю согласных букв в строке не содержащей знаков препинания
- 13.03.2018 03:05
- Информатика
- remove_red_eye 2103
- thumb_up 35
Ответы и объяснения 1
Program enot;
Var s:string;
a:char;
b,n,h,i:integer;
l:real;
begin
read(s);
n:= length(s);
h:=0;
for i:= 1 to n do
case s[i] of
'ы': h:=h+1;
'у':h:=h+1;
'е':h:=h+1;
'и':h:=h+1;
'а':h:=h+1;
'о':h:=h+1;
'ё':h:=h+1;
'э':h:=h+1;
'ю':h:=h+1;
'я':h:=h+1;
end;b:=n-h;
l:=b/n;
writeln(l:4:2);
end.
- 14.03.2018 07:59
- thumb_up 5
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.