Вопрос по информатике:
Строка является палиндромом, если слева направо и справа налево она читается одинаково, например "кабак", "боб", "asdfggf' dsa". Составьте алгоритм и напишите программу, определяющую, является ли строка палиндромом.
- 11.08.2018 21:49
- Информатика
- remove_red_eye 9977
- thumb_up 22
Ответы и объяснения 1
Program gt;
var a,b:string;
l,i:integer;
begin
readln(a);
l:=length(a);
b:='';
for i:=l downto 1 do
b:=b+a[i];
if(a=b)then writeln('YES')else writeln('NO');
end.
- 12.08.2018 13:20
- thumb_up 34
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.