Вопрос по информатике:
Для поступления в институт школьнику Умнову необходимо сдать 4 экзамена: математику, физику, русский и английский. Напишите программу для подсчета среднего балла, полученного школьником на вступительных экзаменах. Оценки по математике, физике и русскому введите с клавиатуры, а вот оценка по английскому языку известна заранее-это "5"(ведь Умнов окончил школу "Наука", а в ней прекрасно преподают английский язык!)
На языке Pascal :3
- 01.09.2017 11:56
- Информатика
- remove_red_eye 19941
- thumb_up 10
Ответы и объяснения 1
Program dfgdf;
var
m,o,r,f:real;
begin
writeln('оценку по математике введите');
readln(m);
if (m>=1) and (m<=5) then
begin
writeln('оценку по русскому введите');
readln(r);
if (r>=1) and (r<=5) then
begin
writeln('оценку по физике введите');
readln(f);
if (f>=1) and (f<=5) then
begin
o:=(m+f+r+5)/4;
writeln('средняя оценка = ',o);
end
else
begin
writeln('не корректный ввод!!!');
end;
end
else
writeln('не корректный ввод!!!')
end
else
writeln('не корректный ввод!!!')
end.
- 02.09.2017 10:19
- thumb_up 12
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.