Вопрос по информатике:
Одномерный массив из 6 элементов заполнить случайным образом числами от 5 до 17. Поменять местами 5-ый и 7-ой элементы массива, а 4-ый элемент
увеличить в 3 раза. Вывести на экран монитора первоначальный и преобразованный массивы в строчку.
Пожалуйста, помогите написать программу в Паскале.
- 08.04.2018 18:14
- Информатика
- remove_red_eye 13003
- thumb_up 51
Ответы и объяснения 1
Program enot;
Var a: array [1..6] of integer;
i,p:integer;
begin
for i:= 1 to 6 do
a[i]:= random(13)+5;
for i:= 1 to 6 do
write(a[i]:4);
writeln();
p:=a[5];
a[5]:=a[6];
a[6]:=p;
a[4]:=a[4]*3;
for i:= 1 to 6 do
write(a[i]:4);
end.
- 10.04.2018 00:26
- thumb_up 5
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.