Вопрос по информатике:
Заполнить массив из 10 элементов случайными числами в интервале [0...10] и выполнить циклический сдвиг массива ВПРАВО.
Формат ввода и вывода данных:
Исходный массив:
4 -5 3 10 -4 -6 8 -10 1 0
Результат:
0 4 -5 3 10 -4 -6 8 -10 1
- 15.11.2017 09:45
- Информатика
- remove_red_eye 6245
- thumb_up 39
Ответы и объяснения 1
Const
n = 10;
var
i, s: integer;
a: array[1..n] of integer;
begin
Writeln('Введите элементы массива через пробел');
for i := 1 to n do Read(a[i]);
s := a[n];
for i := n downto 2 do a[i] := a[i - 1];
a[1] := s;
for i := 1 to n do Write(a[i]:4);
end.
Тестовое решение:
Введите элементы массива через пробел
4 -5 3 10 -4 -6 8 -10 1 0
0 4 -5 3 10 -4 -6 8 -10 1
- 16.11.2017 16:40
- thumb_up 45
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.