Вопрос по информатике:
Составить программу, которая проверяет правопис "жи", "ши" и выводит количество ошибок и исправленную строку
- 09.04.2017 03:43
- Информатика
- remove_red_eye 3417
- thumb_up 49
Ответы и объяснения 1
Var
a,count:longint;
s:string;
begin
writeln('введите строку');
count:=0;
read(s);
while pos('жы',s)>0 do
begin
inc(count);
a:=pos('жы',s);
delete(s,a,2);
insert('жи',s,a)
end;
while pos('шы',s)>0 do
begin
inc(count);
a:=pos('шы',s);
delete(s,a,2);
insert('ши',s,a)
end;
writeln(s);
writeln('всего ошибок: ',count)
end.
- 01.01.1970 00:00
- thumb_up 15
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.