Вопрос по информатике:
С клавиатуры вводят строку. Составить программу, которая удаляет из строки последнее слово
- 10.12.2015 04:01
- Информатика
- remove_red_eye 8947
- thumb_up 20
Ответы и объяснения 1
Program aaa;
var
a,i:longint;
s:string;
begin
read(s);
a:=0;
for i:=1 to length(s) do
if s[i]=' ' then a:=i; //находим последний пробел
delete(s,a,length(s)-a+1); //удаляем из строки последнее слово
writeln(s)
end.
- 11.12.2015 01:21
- thumb_up 22
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.