Вопрос по информатике:
Программисту поставили задачу написать программу,которая по введённому натуральному числу n должна выводить через пробел все нечётные числа из диапазона от 1 до n.Программист торопился и написал следующую программу:
program error;
var
n, i: integer;
begin;
write('9');
readln(n);
for i := 1 to 9 do
if (i mod 2 = 0) then write(i);
writeln
end.
С помощью откладки найдите и исправьте допущенные ошибки.
- 10.09.2018 08:38
- Информатика
- remove_red_eye 7712
- thumb_up 15
Ответы и объяснения 1
Program error;
var
n, i: integer;
begin;
write('Введите натуральное число n =');
readln(n);
for i := 1 to n do
if (i mod 2 = 1) then write(i,' ');
writeln
end.
- 11.09.2018 19:32
- thumb_up 30
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.