Вопрос по информатике:
Задать массив из n элементов. Значения вести с клавиатуры. Написать программу, уменьшающую все элементы массива на единицу. Вывести на экран массив дважды; сначала исходный массив (в строку), а затем с новой строки - полученный массив. Для перехода на новую строку добавить writeln.
Это все в pascal abc
- 25.12.2017 05:20
- Информатика
- remove_red_eye 16889
- thumb_up 35
Ответы и объяснения 1
Const n=10000;
var a:array [1..n] of integer;
b:array [1..n] of integer;
i, k:integer;
begin
Writeln ('Введите число элементов массива');
readln (k);
for i:=1 to k do begin
Writeln ('Введите ',i,' элемент массива'); readln (a[i]); end;
for i:=1 to k do begin b[i]:=a[i]-1; end;
Writeln ('Первоначальный массив:');
for i:=1 to k do begin writeln (a[i]); end;
Writeln ('Конечный массив:');
for i:=1 to k do begin writeln (b[i]); end;
end.
- 26.12.2017 15:49
- thumb_up 40
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.