Вопрос по информатике:
Числа Фибоначчи определяются следующими формулами: f0=f1=1;
fn=fn-1+fn-2, при n>=2 на вход программе подается целое неотрицательное n=<40 выведите n-е число Фибоначчи. Массив в программе не использовать
- 06.09.2015 20:22
- Информатика
- remove_red_eye 16044
- thumb_up 44
Ответы и объяснения 1
Program gt;
var n,f1,f2,i,f:integer;
begin
readln(n);
f1:=1;f2:=1;
for i:=2 to n do
begin
f:=f1+f2;
f1:=f2;
f2:=f;
end;
writeln(f2);
end.
- 07.09.2015 20:51
- thumb_up 22
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.