Вопрос по информатике:
Pascal. паскаль. Написать программу, которая меняет знак всех положительных элементов, расположенных в строке и столбце матрицы с максимальным элементом
- 21.10.2017 18:34
- Информатика
- remove_red_eye 17042
- thumb_up 11
Ответы и объяснения 1
Program gt;
var a:array[1..100,1..100]of integer;
n,m,i,j,max,h,l:integer;
begin
read(n,m);
max:=-maxint;
for i:=1 to n do
for j:=1 to m do
begin
read(a[i,j]);
if(a[i,j]>max)then begin
max:=a[i,j];
h:=i;l:=j;
end;
for j:=1 to m do
a[h,j]:=-a[h,j];
for i:=1 to n do
a[i,l]:=-a[i,l];
a[h,l]:=-a[h,l];
for i:=1 to n do
begin
for j:=1 to m do
write(a[i,j],' ');
writeln;
end;
end.
- 22.10.2017 01:51
- thumb_up 49
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.