Вопрос по информатике:
Составить программу ,которая формирует массив ,содержащий 12 случайных целых чисел ,принадлежащий промежутку [-7;10],и подсчитывает кол-во всех отрицательный чисел
- 17.12.2017 02:49
- Информатика
- remove_red_eye 1129
- thumb_up 15
Ответы и объяснения 2
#include
#include
#include
int main()
{
srand(time(NULL));
int a[12];
int s = 0;
for (int i = 0; i < 12; ++i){
a[i] = rand() % 18 - 7;
if (a[i] < 0) s++;
}
std::cout << s;
return 0;
}
- 18.12.2017 04:16
- thumb_up 21
Паскаль:
var i,t:integer;
a:array[1..12] of integer;
begin randomize;
for i := 1 to 12 do begin
a[i] := round( random(17)-7 );
write(a[i]:3);
end;
t := 0;
for i := 1 to 12 do
if a[i] < 0 then
inc(t);
writeln;
writeln(t);
readln;
end.
- 19.12.2017 17:11
- thumb_up 30
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.