Вопрос по информатике:
Дан массив из 8 элементов целого типа равный :-8,13,4,-6,7,10,-5.Напишите программу ,которая заменит все положительные числа на 1 ,а все отрицательные увеличит на 10.Преобразованный массив вывести на экран в строчку через запятую
- 20.04.2018 22:44
- Информатика
- remove_red_eye 1965
- thumb_up 16
Ответы и объяснения 1
#include
int main() {
int a[] = { -8, 13, 4, -6, 7, 10, -5 };
for (int i = 0; i < 7; ++i)
std::cout << ((a[i] < 0) ? a[i] += 10 : a[i] = 1) << ",";
return 0;
}
- 21.04.2018 11:58
- thumb_up 9
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.