Вопрос по информатике:
№1 составить программу формирования и вывода на экран в строку с тремя знаками после запятой массива, заданного 8-ю вещественными числами из отрезка [-20;20)
№2 составить программу формирования и вывода на кран в обратном порядке массива,заданного 13 цельными числами из отрезка [5,18]
№3 составить программу формирования и вывода на экран в столбец массива, зданного 7 цельными числами из отрезка [104,128]
- 08.12.2017 14:47
- Информатика
- remove_red_eye 3396
- thumb_up 27
Ответы и объяснения 1
1. Program enot;
Var A: array[1..8] of real;
i:integer;
begin
for i:= 1 to 8 do
begin
a[i]:=random(41)-20;
writeln(a[i]:8:3);
end;
end.
2. Program fg;
Var a: array [1..13] of integer;
i:integer;
begin
writeln('первоночальный массив: ');
for i:= 1 to 13 do
begin
a[i]:=random(13)+5;
writeln(a[i], ' ');
end;
writeln('получившийся массив: ');
for i:= 13 downto 1 do
writeln(a[i],' ');
end.
3.
Program enot;
Var a: array [1..7] of integer;
i:integer;
begin
for i:= 1 to 7 do
begin
a[i]:=random(25)+104;
writeln(a[i]);
end;
end.
- 09.12.2017 09:28
- thumb_up 21
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.