Вопрос по информатике:
Помогите пожалуйста!
составьте программу заполнения массива а [1...10] числами фибоначчи. в последовательности фибоначчи значения первых двух элементов равны 1, а значение каждого последующего элемента, начиная с третьего, равно сумме двух предыдущих.
индексы элементов 1 2 3 4 5 6 7 8 9 10
значение элемента 1 1 2 3 5 8 13 21 34 55
- 21.10.2015 23:23
- Информатика
- remove_red_eye 698
- thumb_up 9
Ответы и объяснения 1
Program gt;
var a:array[1..10]of integer;
i:integer;
begin
a[1]:=1;a[2]:=1;
write(a[1],' ',a[2],' ');
for i:=3 to 10 do
begin
a[i]:=a[i-2]+a[i-1];
write(a[i],' ');
end;
end.
- 22.10.2015 16:28
- thumb_up 17
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.