Вопрос по информатике:
Pascal. Написать программу: нахождения цифры в числе с максимальным значением.
9й класс.
- 04.09.2017 13:13
- Информатика
- remove_red_eye 1029
- thumb_up 6
Ответы и объяснения 1
uses crt;
var a,Max,x:integer;
begin
clrscr;
Write('Введите число: ');
readln(a);
Max:=a mod 10;
while a>0 do
begin
x:=a mod 10;
a:=a div 10;
if x>Max then Max:=x;
end;
Writeln('Максимальная цифра: ',Max);
readln;
end.
- 05.09.2017 00:41
- thumb_up 30
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.