Вопрос по информатике:
На языке паскаль:
1. Проверить, делится ли произведение пяти натуральных чисел на первое из них нацело. 2.Определите количество двузначных чисел, сумма квадратов цифр которых делится без остатка на 15.
- 12.09.2017 16:21
- Информатика
- remove_red_eye 1471
- thumb_up 51
Ответы и объяснения 1
1.
uses crt;
var a,b,c,d,e,f:integer;
begin
writeln ('vvedite 5 chisel');
read (a,b,c,d,e);
f:=a*b*c*d*e ;
if (f mod a)=0
then writeln ('delitsa')
else writeln ('nedelitsa');
end.
По поводу второй, не уверен, если под суммой квадратов цифр подразумевается 10 = 1*1+0*0, то эта программа неправильна, её нужно переписать будет.
uses crt;
var a,i,s,t,t1:integer;
begin
for i:=10 to 99 do begin
t:=i div 10; t1:=i mod 10 ;
if (sqr(t)+sqr(t1)) mod 15 = 0
then s:=s+1;
end;
writeln (s);
end.
- 14.09.2017 00:54
- thumb_up 31
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.