Вопрос по информатике:
ПОМОГИТЕ ОЧЕНЬ НАДО!
Дано целое число n, которое больше либо равно 0 и меньше либо равно 9.
Написать программу, вычисляющую сумму всех двузначных чисел в записи которых нет n.
- 21.06.2016 14:58
- Информатика
- remove_red_eye 7583
- thumb_up 44
Ответы и объяснения 1
Var n,i,one,dec,sum:integer;
begin
writeln('Введите n'); readln(n);
sum:=0;
for i:=10 to 99 do begin
one:= i mod 10; dec:=i div 10;
if (onen)and(decn) then sum:=sum+i;
end;
writeln(sum);
readln
end.
- 22.06.2016 03:06
- thumb_up 35
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.