Вопрос по информатике:
Составьте программу, выводящую на экран числа от 1 до 10, а также их квадраты и кубы следующим образом:
1 1 1
2 4 8
3 9 27
----------------
10 100 1000
- 19.02.2016 01:55
- Информатика
- remove_red_eye 5979
- thumb_up 24
Ответы и объяснения 1
Зависит от того, в чем работаете(Паскаль, С). Как самый просто вариант в паскале("в лоб"):
uses crt
var i:integer;
begin
i:=1; {присваиваем 1}
repeat
writeln(); {пустая строка}
write(i); {пишем само число i}
write(' '); {ставим пробел}
write(exp(2*ln(i)):2:0); {считаем квадрат числа i}
write(' '); {пробел}
write(exp(3*ln(i)):2:0); {считаем куб числа i}
i:=i+1; {новое значение i}
until i>10; {условие окончания i>10}
readkey; {закрытие по нажатию программы}
end.
- 20.02.2016 01:03
- thumb_up 28
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.