Вопрос по информатике:
1. составить программу входе которой определяется входит ли цифры 4 или 7 в данной 2х значное число.
2.Составить программу входи работы которой определяется является ли данное число кратное и оканчивающиеся на 3
- 18.01.2015 13:41
- Информатика
- remove_red_eye 15719
- thumb_up 45
Ответы и объяснения 1
Язык не указан, Default-Language это C. На нём и напишу.
1.
#include
int main() n / 10 == 4
Для порядку скажу что на Perl это можно реализовать проще.
#!perl
%h { 4 => 0, 7 => 0};
;
if (exists $h{$_%10} || exists $h{$_/10}) {
print "YES\n";
else {
print "NO\n";
}
Но мы ушли от темы. Итак, 2. Тут всё ещё проще:
#include
int main() {
int n;
scanf("%d", &n);
if (!(n % 3))
printf("Multiple of 3\n");
else
printf("Not multiple of 3\n");
if (n % 10 == 3)
printf("Ends by 3\n");
else
printf("Not ends by 3\n");
return 0;
}
Тут более простой реализации на другом известном мне языке нету, так что приводить дополнительно ничего не буду.
- 19.01.2015 11:36
- thumb_up 13
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.