Вопрос по информатике:
7.4. Описать массив из тридцати записей—точек на плоско- сти. Заполнить его случайно выбранными координатами—числами в диапазоне от −10 до 100.
Написать функцию, которая получает две точки и возвращает расстояние между этими точками. Используя написанную функцию определить, какая из точек находится на наибольшем расстоянии от начала координат. Вывести на экран номер точки в массиве и ее координаты. Если решений несколько, вывести все.
Помогите написать программу не пойму как сделать.
- 23.03.2017 12:46
- Информатика
- remove_red_eye 14200
- thumb_up 43
Ответы и объяснения 1
Var
K:array[1..2,1..13] of integer;
i,j,ind,x,y:integer;
MAX:real;
function RAST(x1,x2,y1,y2:integer):real;
begin
RAST:=sqrt(sqr(x2-x1)+sqr(y2-y1));
end;
begin
MAX:=-2*sqr(-10-1);
randomize;
writeln('Исходные точки:');
for j:=1 to 13 do
begin
writeln('Точка № ',j,', с координатами(X,Y)');
for i:=1 to 2 do
begin
K[i,j]:=random(110) - 10;
write(K[i,j],' ');
end;
writeln;
end;
for i:=1 to 13 do
if RAST(0,K[1,i],0,K[2,i])>MAX
then
begin
MAX:=RAST(0,K[1,i],0,K[2,i]);
x:=K[1,i];
y:=K[2,i];
ind:=i;
end;
writeln('Номер точки: ',ind,' Координаты: ',x,' ; ',y);
end.
- 24.03.2017 11:40
- thumb_up 50
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.