Вопрос по информатике:
Напишите функцию вычесляющею длину отрезка по координатам его концов с помощью этой функции напишите программу вычесляющую периметр треугольника по координатам его ершин
- 06.09.2018 21:42
- Информатика
- remove_red_eye 11793
- thumb_up 29
Ответы и объяснения 1
Var x1, y1, x2, y2, x3, y3, P: real;
function length(x1: real; y1: real; x2: real; y2: real): real;
begin
length := sqrt(sqr(x1 - x2) + sqr(y1 - y2));
end;
begin
read(x1, y1, x2, y2, x3, y3);
P := length(x1, y1, x2, y2) + length(x3, y3, x2, y2) + length(x1, y1, x3, y3);
writeln('Perimeter is ', P);
end.
------------------------------
#include
#include
float length(float x1, float y1, float x2, float y2)
{
return pow((x1 - x2) * (x1 - x2) + (y1 - y2) * (y1 - y2), 0.5);
}
int main()
{
float x1, y1, x2, y2, x3, y3, P;
std::cin >> x1 >> y1 >> x2 >> y2 >> x3 >> y3;
P = length(x1, y1, x2, y2) + length(x3, y3, x2, y2) + length(x1, y1, x3, y3);
std::cout << "Perimeter is " << P;
}
- 07.09.2018 00:24
- thumb_up 8
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.