Вопрос по информатике:
У меня есть готовый код паскаля (но я не знаю, по какой причине у меня не получается его увидеть как требуется в задании(Составьте программу, которая определяет количество отрицательных, количество положительных и количество нулей среди введенных чисел. Значение N вводится с клавиатуры.)
Можно переделать код, но без использования uses crt и т.д. Сделать нужно с циклом for while и/или repeat. К слову, пользуюсь Pascal.ABC.NET (не знаю, какие значения и где нужно вводить, чтобы получить результат, требуемый в задании).
program zadacha3;
var
n, o, p, k, i: integer;
a: real;
begin
repeat
write('N = ');
readln(n);
until (n > 0);
i := 0;
k := 0;
p := 0;
o := 0;
repeat
write('Ввод:');
readln(a);
i := i + 1;
if a < 0 then o := o + 1 else
if a > 0 then p := p + 1 else k := k + 1;
until i = n;
writeln('Кол-во положительных: ', p);
writeln('Кол-во отрицательных: ', o);
writeln('Кол-во нулей: ', k);
readln;
end.
- 11.05.2018 21:01
- Информатика
- remove_red_eye 654
- thumb_up 17
Ответы и объяснения 1
Не очень корректно объяснили, но если правильно вас понял:
Program G;
Var n, z, m, p: integer;
Begin
z:=0;
p:=0;
m:=0;
Writeln('Введите число n. Число 9999 завершает цикл.');
Readln(n);
While n9999 do
Begin
If n=0 then inc(z);
else if n>0 then inc(p);
else inc(m);
Writeln('Введите число');
Readln(n);
End;
Writeln('Было введено ', z, ' нулей.');
Writeln('Было введено ', p, ' положительных чисел.');
Writeln('Было введено ', m, ' отрицательных чисел.');
Readln;
End.
- 12.05.2018 05:39
- thumb_up 39
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.