Вопрос по информатике:
Составить программу формирующую двухмерный массив 10^10 заполненный нулями,затем вывести на экран,затем преобразовать таким образом чтобы элементы главной диагонали были равны 1
- 27.11.2017 19:16
- Информатика
- remove_red_eye 16787
- thumb_up 21
Ответы и объяснения 1
Program array
var
i,j:integer;
a: array [1..10, 1..10] of integer;
begin
for i:=1 to 10 do begin
for j:=1 to 10 do begin
a[i,j] = 0;
writeln(a[i,j],"\t");
end;
end;
for i:=1 to 10 do begin
for j:=1 to 10 do begin
if (i = j) then a[i,j] = 1;
writeln(a[i,j],"\t");
end;
end;
end;
- 29.11.2017 00:05
- thumb_up 49
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.