Вопрос по информатике:
Напишите программу, которая:
А) определяет, есть ли среди цифр заданного целого трехзначного числа одинаковые;
Б) явл. ли число "перевертышем", т.е. Числом, десятичная запись которого читается одинаково слева направо и справа налево.
- 26.02.2018 10:03
- Информатика
- remove_red_eye 16507
- thumb_up 30
Ответы и объяснения 1
А) Program cifr;
Uses crt;
var n,l:integer; s:string;
Begin
read(n);
str(n,s);
l:=length(s);
if (s[1]s[2]) and (s[2]s[3]) and (s[1]s[3])
then begin writeln('Одинаковых цифр нет') end
else writeln('Одинаковые цифры присутствуют');
end.
Б) Program Stroke;
Uses Crt;
Var s: string; n,i,j,l: integer;
Begin
ReadLn(n);
str(n,s);
l:=length(s);
j:=0;
for i := 1 to l div 2 do begin
if s[i]=s[length(s)-i+1]
then j:=1 end;
if j=1 then
writeln('Да, число является палиндромом')
else writeln('Нет, число не является палиндромом');
End.
- 27.02.2018 01:29
- thumb_up 34
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.