Вопрос по информатике:
Написать программу с использованием оператора цикла(постусловия).
Резервуар имеет форму сферы; его внутренний радиус равен R см Найдите объем(V) жидкости в зависимости от от уровня h воды от низшей точки его дна. Величина h изменяется от 0 до 2 с шагом 0,1. Объем V шарового сегмента (заполненого жидкостью) вычисляется по формуле πh²(R-h/3).
- 17.06.2017 15:00
- Информатика
- remove_red_eye 8883
- thumb_up 39
Ответы и объяснения 1
const
pi=3.14;
var
h,V,R: real;
begin
writeln('Введите радиус');
Readln(R);
h:=0;
repeat
V:=pi*sqr(h)*(R-h/3);
writeln('V(',h,')=', V);
h:=h+0.1;
until h>2.1;
end.
- 18.06.2017 09:57
- thumb_up 32
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.