Вопрос по информатике:
Хотя бы что-нибудь!
Помогите решить задачи в паскале!!!
Составить программу для:
1)Решения линейного уравнения ах + в = 0 (а,в ≠ 0).
2)Найти площадь кольца по заданным внешнему и внутреннему радиусам
3)Даны катеты прямоугольного треугольника, Найти его площадь и периметр
4)Даны два числа. Найти среднее арифметическое их модулей
5)Даны координаты двух точек на плоскости. Вычислить расстояние между ними
6)Даны два основания и высота прямоугольной трапеции. Найти ее площадь и периметр
7)Найдите разность между трехзначным числом и произведением его цифр
- 26.08.2016 06:24
- Информатика
- remove_red_eye 14037
- thumb_up 7
Ответы и объяснения 1
1) var a,b,x:real;
begin
write ('введите числа а и b: '); readln(a,b);
x:=-b/a;
writeln('x= ',x);
end.
2) var r1,r2,s:real;
begin
write ('введите размеры внешнего и внутреннего радиусов: '); read(r1,r2);
s:=pi*r1*r1-pi*r2*r2;
write ('Площадь кольца = ',s);
end.
3) var a,b,c,s,p:real;
begin
write ('введите длины катетов: '); read(a,b);
s:=a*b/2;
c:=sqrt(a*a+b*b);
p:=a+b+c;
write ('Площадь треугольника = ',s);
write ('Периметр треугольника = ',p);
end.
4) var a,b,sr:real;
begin
write ('введите числа а и b: '); readln(a,b);
sr:=(abs(a)+abs(b))/2;
writeln('среднее арифметическое модулей = ',sr );
end.
5) var x1,y1,x2,y2,r:real;
begin
write ('введите координаты точек: '); readln(x1,y1,x2,y2 );
r:=sqrt ( sqr(x2-x1)+sqr (y2-y1));
writeln('расстояние = ',r );
end.
6) var a,b,h, s, p:real;
begin
write ('введите длины оснований и высоту трапеции: '); readln(a,b,h);
s:=(a+b)*h/2;
p:=a+b+h+sqrt (sqr(abs(a-b))+h*h);
write ('Площадь трапеции = ',s);
write ('Периметр трапеции= ',p);
end.
7) var a,e,d,s, p:integer;
begin
write ('введите трехзначное число: '); readln(a);
e:=a mod 10; s:=a div 100;
d:= (a div 10) mod 10; p:=e*d*s;
write ('разность между трехзначным числом и его произведением = ',a-p);
end.
к твоему комментарию
var x,s,m,c: integer;
begin
write('введите количество секунд: ');readln(x);
c:=x div 3600;
m:= (x mod 3600) div 60;
s:=(x mod 3600) mod 60;
writeln('прошло ',c,' часов ',m,' минут ', s,' секунд ');
end.
- 27.08.2016 23:40
- thumb_up 25
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.