Вопрос по информатике:
Составьте программу которая формирует массив из 20 целых чисел и вычисляет средние арифметическое нечетный чисел
- 01.07.2018 09:14
- Информатика
- remove_red_eye 18735
- thumb_up 9
Ответы и объяснения 1
Var mas:array[1..20] of integer;
i, sum:integer;
begin
for i:=1 to 20 do
begin
mas[i]:=random(99);
write(mas[i], ' ');
end;
writeln;
i:=1;
while(i < 20) do
begin
sum:=sum+mas[i];
i:=i+2;
end;
writeln('Среднее арифметическое нечётных элементов массива ', sum/10);
end.
- 02.07.2018 21:26
- thumb_up 23
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.