Вопрос по информатике:
Написать программу на Free Pascal которая переводит число из десятичной системы в двоичную
- 09.05.2017 13:11
- Информатика
- remove_red_eye 8718
- thumb_up 22
Ответы и объяснения 1
Function ToBinaryString(x: integer): string;
var r, s: string;
begin
if x < 0 then begin
s := '-';
x := -x;
end;
while x 0 do begin
r := Chr((x and 1) or 48) + r;
x := x shr 1;
end;
ToBinaryString := s + r;
end;
var x: integer;
begin
readln(x);
writeln(ToBinaryString(x));
end.
- 01.01.1970 00:00
- thumb_up 16
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.