Вопрос по информатике:
Написать программу на Паскале: Среди 10 целых положительных и
отрицательных чисел:
1. Найти
максимальное и минимальное значения.
2. Среднее арифметическое среди трехзначных,
оканчивающихся на 1 и кратных 7.
- 09.11.2017 12:19
- Информатика
- remove_red_eye 9188
- thumb_up 7
Ответы и объяснения 2
Var
i, e, min, max, s, n: integer;
c: real;
begin
min := 32767; max := -32768; s := 0; n := 0;
Write('Введите 10 чисел через пробел ');
for i := 1 to 10 do
begin
Read(e);
if max < e then max := e;
if min > e then min := e;
if (e >= 100) and (e <= 999) then
if (i mod 10 = 1) and (i mod 7 = 0) then
begin n := n + 1; s := s + i end
end;
Writeln('max=', max, ', min=', min);
if n > 0 then Writeln('Искомое среднее равно ', s / n:0:5)
else Writeln('Нет трехзначных чисел, оканчивающихся на 1 и кратных 7')
end.
- 01.01.1970 00:00
- thumb_up 47
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.