Вопрос по информатике:
1)составьте программу вычисления суммы чисел в диапазоне от 45 до 115 45+....+115
2)Составьте программу которая выводит на экран числа кратные 2 и 13 в диапазоне от 2 до 150
3)Дано вещественное число А и целое число N(>0).Испульзуя один цикл вывести все целые степени числа А от 1 до N
------------------------ОПЕРАТОР WHILE
- 06.07.2018 15:18
- Информатика
- remove_red_eye 8549
- thumb_up 19
Ответы и объяснения 1
1)var i,sum:integer;
begin
sum:=0;
i:=45;
while (i<=115) do begin
sum:=sum+i;
i:=i+1;
end;
writeln( 'Сумма = ', sum );
end.
2)var i:integer;
begin
i:=2;
while (i<=150) do begin
If (i mod 2=0) and (i mod 13=0) then
writeln(i);
i:=i+1;
end;end.
3)var c,A,i,N:integer;
begin
write('Введите целое число (N>0) N = ');read(N);
write('Введите целое число A = ');read(A);
c:=1;
i:=1;
while (i<=N) do begin
c:=c*A;
i:=i+1;
Writeln('A в степени ',i,' := ',c);
end;end.
- 07.07.2018 23:49
- thumb_up 24
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.