Вопрос по информатике:
Составить программу для вычисления длины n-мерного вещественного вектора Х=(Х1, Х2, ..., Xn) по формуле
L=sqrt(((X1)^2)+((X2)^2)+ ...+((Xn)^2))
- 16.02.2018 01:28
- Информатика
- remove_red_eye 15123
- thumb_up 22
Ответы и объяснения 1
Const
nm = 50;{максимальная размерность вектора}
var
i, n: integer;
x: array[1..nm] of real;
s: real;
begin
Write('Введите размерность вектора n -> ');
Readln(n);
Write('Вводите координаты вектора через пробел ');
s := 0;
for i := 1 to n do
begin
Read(x[i]);
s := s + sqr(x[i])
end;
Writeln('Длина вектора равна ', sqrt(s):0:4)
end.
Тестовое решение:
Введите размерность вектора n -> 7
Вводите координаты вектора через пробел -3.54 0.532 2.6 12 -3 0 1.47
Длина вектора равна 13.2188
- 17.02.2018 13:28
- thumb_up 44
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.