Вопрос по информатике:
Напишите программу,которая получает два целых числа и находит их произведение не используя операцию умножения. учтите, что числа могут быть отрицательными.пример :введите два числа: 10-15,10*(-15)=-150
- 24.10.2015 20:53
- Информатика
- remove_red_eye 15034
- thumb_up 29
Ответы и объяснения 1
Var a, b, prod, i: integer;
begin
writeln('Введите два числа: ');
readln(a, b);
prod := 0;
if (b < 0) then
for i := b to -1 do
dec(prod, a)
else
for i := 1 to b do
inc(prod, a);
writeln(prod)
end.
- 25.10.2015 11:41
- thumb_up 20
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.