Вопрос по информатике:
Составьте программу, которая формирует массив из 40 случайных целых чисел от 0 до 20 и вычисляет сумму чисел, кратных 3.
Помогите пожалуйста!!
- 21.10.2017 11:09
- Информатика
- remove_red_eye 18424
- thumb_up 7
Ответы и объяснения 1
Текст программы на языке Pascal:
program p1;
var a: array [1..40] of integer;
var i,c:integer;
begin
c:=0;
for i:=1 to 40 do
begin
a[i]:=random(20);
write (a[i],' ');
if (a[i] mod 3) = 0
then c:=c+a[i];
end;
writeln;
writeln (c);
end.
- 22.10.2017 19:52
- thumb_up 26
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.